Tetra/Prism Mesh Generation for an Aorta

This tutorial demonstrates the generation of a tetra/prism mesh for an aorta, starting from STL data.

The aorta geometry used in this tutorial is courtesy of Marc Horner, an ANSYS, Inc. engineer, and Materialise Inc., who extracted the geometry from the MRI scan images.

**Figure: Aorta Geometry**

This tutorial demonstrates how to do the following:

- Import STL data into ANSYS ICEM CFD.
- Set up global and part parameters for meshing.
- Generate the mesh using the Octree approach.
- Generate the mesh using the Delaunay approach.
- Examine the mesh using cut-planes.
- Smooth the mesh to improve the mesh quality.

**Preparation**
- Step 1: Creating Parts
- Step 2: Creating the Material Point
- Step 3: Generating the Octree Mesh
- Step 4: Generating the Delaunay Mesh
- Step 5: Saving the Project

**Further Setup**
Preparation

1. Copy the input geometry file (Aorta.stl) from the ANSYS installation directory under v140/icemcfd/Samples/CFD_Tutorial_Files/Aorta to the working directory.

2. Start ANSYS ICEM CFD and import the geometry (Aorta.stl).

   File > Import Geometry > STL

   a. Select the STL file (Aorta.stl) in the Open dialog box and click Open.

   The STL import options dialog will appear.

   b. Retain the selection of Generate for Part names and click Done.

   The imported geometry will be displayed in the graphics window.

   c. Select (Solid Full Display) from the Solidframe Display Options menu.

   Figure: The Aorta Geometry

Step 1: Creating Parts

The imported geometry comprises a single part. You will split the geometry and define the parts in this step.

1. Split the geometry.

   Geometry > Create/Modify Surface > Segment/Trim Surface
a. Select **By Angle** from the **Method** drop-down list.

b. Click (Select surface(s)) and select the aorta surface. Click the middle-mouse button to accept the selection.

c. Enter 35 for **Angle** and click **Apply**.

2. Create the **INLET** part.

   ![Create Part](image)

   a. Enter **INLET** for **Part** in the **Create Part DEZ**.

   b. Retain the selection of (Create Part by Selection) and click (Select entities).

      *The Select geometry toolbar will appear.*

   c. Select the inlet surface (*Figure: Aorta—Parts (p. 128]*) and click the middle-mouse button to accept the selection.

   d. Click **Apply**.

3. Create the **OUTLET** part.

   a. Enter **OUTLET** for **Part** in the **Create Part DEZ**.

   b. Click (Select entities) and select the outlet surfaces (*Figure: Aorta—Parts (p. 128]*). Click the middle-mouse button to accept the selection.
Tip

Use the **Toggle dynamics** (hotkey F9) option to toggle between selection mode and dynamic mode to better orient the geometry for easier selection of entities. You can also hold down the **CTRL** key to toggle between selection mode and dynamic mode.

c. Click **Apply**.

---

**Note**

You could also create a unique part for each output surface for easier display/selection in the solver.

---

**Figure: Aorta—Parts**

4. Rename the part comprising the arterial wall to **AORTA_WALL**.

   ![RMB → AORTA.MESH.PART.1 LMB → Rename](Image)

   • Enter **AORTA_WALL** in the **New name** dialog and click **Done**.

5. Extract the feature curve from the inlet and outlet surfaces.

   ![Geometry > Create/Modify Curve > Extract Curves from Surfaces](Image)
a. Expand the **Parts** section of the tree and deselect **AORTA_WALL**.

[Diagram: Expand Parts and select AORTA_WALL]

*The graphics display shows only the inlet and outlet surfaces.*

b. Click **Select surface(s)** and then **Select all appropriate visible objects** in the **Select geometry** toolbar.

*All the inlet and outlet surfaces will be selected.*

c. Select **Create New** in the **Extract Edges** list.

d. Click **Apply**.

6. Enable **AORTA_WALL** in the **Parts** section of the tree.

[Diagram: Parts and select AORTA_WALL]

7. Select **WireFrame Simple Display** to restore the wireframe display.

**Step 2: Creating the Material Point**

**Geometry > Create Body**
1. Enter FLUID for **Part**.

2. Retain the selection of **Centroid of 2 points** for **Location**.

3. Click (Select location(s)) and select two locations such that the midpoint lies within the volume (see **Figure: Selection of Points for Creating Material Point** (p. 130)). Click the middle-mouse button to accept the selection of the points.

**Figure: Selection of Points for Creating Material Point**

4. Click **Apply**.

   The **FLUID** part appears under **Parts** in the display control tree. Select (WireFrame Full Display) and rotate the geometry to confirm that the new material point is within the volume and does not just appear so from one perspective.

5. Click (Solid Full Display) to restore the shaded surface visualization.
Step 3: Generating the Octree Mesh

1. Measure the smallest diameter on the aorta geometry.

   You will use this value to set the minimum size for the mesh.

   a. Zoom in to the smallest diameter in the graphics display.

   b. Click (Measure Distance) and select a pair of locations to measure the diameter (Figure: Measuring the Smallest Diameter (p. 131)).

   **Figure: Measuring the Smallest Diameter**

   ![Image of measuring the smallest diameter]

   The distance is reported to be around 1.5.

2. Assign the mesh sizes.
a. Enter 2 for **Max element**.

b. Select **Enabled** for **Curvature/Proximity Based Refinement** and enter 0.5 for **Min size limit**.

c. Set **Refinement** to 18.

d. Click **Apply**.

3. Specify the parts for prism creation.

   Mesh > Part Mesh Setup

   ![Mesh > Part Mesh Setup]

   a. Enable **prism** for **AORTA_WALL**.

   b. Retain the default settings for other parameters.

   c. Click **Apply** and then **Dismiss**.

   The prism height is set to zero which allows it to “float”. The prisms will have a variable thickness calculated to reduce the volume change between the last prism and the adjacent tetra.

4. Modify the global prism settings.

   Mesh > Global Mesh Setup > Prism Meshing Parameters

   ![Mesh > Global Mesh Setup > Prism Meshing Parameters]
a. Enter 0.25 for **Ortho weight**.

b. Set the **Number of volume smoothing steps** to 0.

c. Retain the default settings for the other parameters and click **Apply**.

5. Compute the mesh.

   Mesh > Compute Mesh > Volume Mesh
a. Ensure that the Mesh Method is set to Robust (Octree).
b. Enable Create Prism Layers.
c. Click Compute.

*The progress will be reported in the message window.*

6. Examine the mesh *(Figure: Octree Mesh for the Aorta (p. 135)).*
   a. Disable the display of surfaces.
   
   ![Geometry LMB Surfaces](image)

   b. Select Solid & Wire.
   
   ![Mesh RMB Shells LMB Solid & Wire](image)
Figure: Octree Mesh for the Aorta

Note

Some solvers may not like the volume transitions in the Octree mesh. Step 4 explains how you can replace the Octree volume mesh with a Delaunay volume mesh for smoother volume transition.

7. Use cut planes to examine the mesh.
   a. Select **Wire Frame**.

   ![Wire Frame icon]

   b. Select **Manage Cut Plane**.

      ![Manage Cut Plane icon]

   c. Set the following parameters:
      i. Retain the selection of **by Coefficients** in the **Method** drop-down list.
      ii. Set **Fraction Value** to 0.95.
      iii. Click **Apply**.

   d. Enable the display of volumes in the display control tree.

      ![Volumes icon]

   e. Select **Solid & Wire**.
f. Examine the mesh using a cut plane in the X direction.
   i. Select **Middle X Plane** in the **Method** drop-down list.
   ii. Set **Fraction Value** to 0.62.
   iii. Click **Apply**.

   Manipulate the display to obtain the view shown in **Figure: Cut Plane in X Direction for the Octree Mesh** (p. 137).
g. Disable **Show Cut Plane** in the **Manage Cut Plane** DEZ.

8. Smooth the mesh.

*The smoothing approach involves initial smoothing of the interior elements without adjusting the prisms. After initial smoothing, you will smooth the prisms as well.*

**Edit Mesh > Smooth Mesh Globally**

*The quality histogram appears in the right hand corner.*
a. Enter 20 for **Smoothing iterations** and 0.2 for **Up to value**.

b. Retain the selection of **Quality** in the **Criterion** drop-down list.

c. Select **Freeze** for **PENTA_6**.

d. Retain the other settings and click **Apply**.

   *The quality histogram will be updated.*

e. Enter 5 for **Smoothing iterations** and 0.01 for **Up to value**.

f. Select **Smooth** for **PENTA_6**.

g. Click **Apply**.

   *The quality histogram will be updated accordingly (Figure: Histogram—Quality After Smoothing (p. 138)).*

**Figure: Histogram—Quality After Smoothing**

9. Check the mesh for any errors that may cause problems during the analysis.

   **Edit Mesh > Check Mesh**

   ![Graph](image-url)
a. Retain the default set of checks.

b. Click **Apply** to check for errors and possible problems in the mesh.

*Make sure no errors/problems are reported during the check.*

### Step 4: Generating the Delaunay Mesh

In this step, you will replace the Octree mesh with the Delaunay mesh because it has a smoother volume transition.

1. Set the volume mesh parameters.

   **Mesh** > **Global Mesh Setup** > **Volume Meshing Parameters**
a. Select **Quick (Delaunay)** from the **Mesh Method** drop-down list.

b. Retain the other settings and click **Apply**.

2. Compute the mesh.

![Mesh > Compute Mesh > Volume Mesh]
a. Ensure that **Quick (Delaunay)** is selected in the **Mesh Method** drop-down list.
b. Disable **Create Prism Layers**.
   
   *The **Create Prism Layers** option can be disabled as the prisms were already generated during the Octree mesh generation.*
c. Ensure that **Existing Mesh** is selected in the **Select** drop-down list.
d. Ensure that **Load mesh after completion** is enabled.
e. Click **Compute**.
   
   *The progress will be reported in the message window.*

3. Examine the mesh using cut planes.
   a. Examine the mesh using a cut plane in the Z direction.
      
      *Manipulate the display to obtain the view shown in Figure: Cut Plane Z Direction for the Delaunay Mesh (p. 142).*
Figure: Cut Plane Z Direction for the Delaunay Mesh

b. Examine the mesh using a cut plane in the X direction.

Manipulate the display to obtain the view shown in Figure: Cut Plane in X Direction for the Delaunay Mesh (p. 142).

Figure: Cut Plane in X Direction for the Delaunay Mesh

From Figure: Cut Plane Z Direction for the Delaunay Mesh (p. 142) and Figure: Cut Plane in X Direction for the Delaunay Mesh (p. 142), you can see that the mesh transition is now much smoother.

4. Smooth the mesh.
As the prisms were smoothed in the previous step, you will smooth the other elements without adjusting the prisms.

**Edit Mesh > Smooth Mesh Globally**

a. Enter 20 for **Smoothing iterations** and 0.2 for **Up to value**.
b. Retain the selection of **Quality** in the **Criterion** drop-down list.
c. Select **Freeze** for **PENTA_6**.
d. Retain the other settings and click **Apply**.

The quality histogram will be updated.

5. Check the mesh for any errors that may cause problems during the analysis.

**Edit Mesh > Check Mesh**

**Step 5: Saving the Project**

1. Save the geometry and mesh.

**File > Save Project As...**

2. Select the solver.

**Output > Select solver**

a. Select **ANSYS Fluent** from the **Output Solver** drop-down list.
b. Retain **NASTRAN** in the **Common Structural Solver** drop-down list.
c. Click **Apply**.

3. Set the appropriate boundary conditions.

**Output > Boundary conditions**

a. Set the boundary condition for **AORTA_WALL** to **wall**.
   i. Click **Create new** under **AORTA_WALL**.
ii. Select wall from the list of Boundary Conditions in the Selection dialog box.

iii. Click Okay.

iv. Enter the required zone ID.

b. Similarly, set the boundary conditions for INLET to velocity-inlet and OUTLET to pressure-outlet, exhaust-fan, outlet-vent.

c. Set the boundary conditions for FLUID to fluid.

d. Click Accept after setting the boundary conditions.
Note

**Mixed/unknown** refers to the dimension of the elements in a part. If a part contains all volume elements, it clearly belongs in the surfaces branch. However, if a part has surfaces, curves and points, the mesh will contain a mixture of element types and the part will be located in the **Mixed/unknown** branch of the tree. If you apply wall properties, these are applied to the shells in that part only.

4. Write the input file for ANSYS FLUENT.

**Output > Write input**

a. Select the appropriate .uns file.

The ANSYS Fluent dialog will appear.

![ANSYS Fluent Dialog](image)

b. Select Yes for Scaling and enter 0.001 for x scaling factor, y scaling factor, and z scaling factor, respectively.

*The mesh was created in units of millimeters (mm), and hence needs to be scaled to meters.*

c. Retain the default settings for other parameters.

d. Enter aorta for **Output file**.

e. Click **Done**.

---

**Note**

You can read the saved mesh file in ANSYS FLUENT and proceed to setup and solve for transient, laminar flow.

---

**Further Setup**

You can solve this example for transient, laminar flow using ANSYS FLUENT. A basic setup could include the following:
- Material properties
  - Density: 1060 kg/m\(^3\)
  - Viscosity: 0.0035 kg/m\(-s\)
- Solver setup: transient, laminar flow
- Boundary conditions
  - The transient velocity profile (one cycle) is available with the tutorial example file (AorticIn-flowWaveform.prof). The profile assumes a cardiac output of 6.8 l/min and 75 beats per minute.

**Note**

Run at least 1.5 cycles to remove the effects of the initial condition.

- Assume zero pressure at the outlets.

- Post-processing
  - The periodic solution can be visualized by plotting the inlet pressure for 3 cycles.
  - Other results of interest include wall shear, static pressure on the wall, and velocities along the length.

A more advanced setup could include two-way FSI, which can be done using ANSYS.